Tutoriel Excel: Comment supprimer les doublons

Tutoriel Excel: Comment supprimer les doublons

Dans le tutoriel d’aujourd’hui j’expliquerais 3 méthodes faciles pour supprimer les doublons Excel.

En effet, supprimer les doublons dans Excel peut être facile à faire manuellement si vous avez une petite feuille de calcul. Cependant si vous travaillez sur un grand ensemble de données cela sera fatiguant et vous prendra beaucoup de temps. Excel intègre des outils intéressant pour vous aidez à le faire d’une manière semi-automatique sans vous faire perdre du temps.

Table des matières

Supprimer les doublons Excel à l’aide de la commande « Supprimer les doublons »

Utiliser le filtre avancé d’Excel

Supprimer les doublons à l’aide de la fonction Excel NB.SI

    Étape 1: mettre en surbrillance les doublons

    Étape 2: supprimer les lignes en double

Supprimer les doublons Excel à l’aide de la commande « Supprimer les doublons »

1.       Pour commencer, ouvrez un classeur Excel ou créez-en un nouveau et ajoutez-y des données facultatifs.

Ouvrir nouveau classeur

2.       Ensuite, sélectionnez la ou les colonnes pour rechercher les doublons.

sélectionner la liste qui contient les doublons

3.       Puis accédez à l’onglet Données en haut du ruban.

Aller sur l'onglet Données

4.       Puis cliquez sur l’option « Supprimer les doublons » qui se trouve dans Outils de données comme illustrés ci-dessous.

sélectionner l'option supprimer les doublons Excel

5.       Ensuite, une boite de dialogue apparaîtra, appuyez sur le bouton OK. Cela supprimera les éléments en double de votre ensemble de données.

Supprimer les doublons Excel-cliquez sur OK

6.       Finalement, une boite de dialogue s’affiche et qui indique le nombre de doublons supprimés.Dans mon cas Excel à supprimé 3 doublons.

Nombre de doublons supprimées

Supprimer les doublons à l’aide du filtre avancé d’Excel

Le filtre avancé d’Excel est une option très intéressante et très utile. En effet il permet de détecter les enregistrements uniques d’un ensemble de données et les copier vers un autre emplacement tout en gardant une seule occurrence pour les entrées dupliquées.

Pour supprimer les doublons à l’aide du filtre avancé:

1.       En premier lieu, sélectionnez la ou les colonnes à filtrer:

supprimer les doublons Excel-méthode 2

2.       Puis accédez à l’onglet Données et sélectionnez l’option Filtre avancé comme le montre la capture ci-dessous:

supprimer les doublons Excel-Le filtre avancé

3.       Ainsi, la boîte de dialogue filtre avancé s’affiche (voir ci-dessous).

Boite de dialogue Filtre avancé

4.       Sélectionnez en premier lieu l’option Copier vers un autre emplacement;

Choisir copier vers un autre emplacement

5.       Ensuite, dans le champ Copier dans, entrez l’adresse de la cellule dans laquelle vous souhaitez placer la nouvelle liste :

choisir la cellule de destination

6.       Ensuite, n’oubliez pas de cochez la case Extraction sans doublon.

Cocher la case extraction sans doublon

7.       Finalement, cliquez sur OK. Ainsi la nouvelle liste de données apparaît dans l’emplacement choisis!

Supprimer les doublons Excel-résultat

Supprimer les doublons à l’aide de la fonction Excel NB.SI

Étape 1: mettre en surbrillance les doublons

La troisième méthode pour supprimer les doublons Excel consiste à utiliser la fonction NB.SI

Pour illustrer cela, je vais utiliser l’ensemble de données ci-desous:

Supprimer les doublons Excel-Méthode 3-utiliser la fonction NB.SI

Pour trouver les doublons, je vais utiliser la fonction NB.SI pour calculer le nombre d’occurrences de chaque entrée comme ci-dessous (Pour moi j’ai mis la formule dans la colonne D) :

Saisir la formule NB.SI pour détecter les doublons Excel

Le format de la fonction NB.SI dans la cellule D2 est:

=NB.SI(C$2:C2;C2)

Lorsque la formule est copiée dans la colonne D, elle devient:

=NB.SI(C$2:C3;C3) dans la cellule D3

=NB.SI(C$2:C4;C4) dans la cellule D4

=NB.SI(C$2:C5;C5) dans la cellule D5

etc.

Étape 2: supprimer les lignes en double

Après avoir calculer le nombre d’occurrences pour chaque entrée en utilisant la fonction NB.SI, il nous reste de supprimer les lignes ayant un nombre supérieur à 1.

1.       Sélectionnez d’abord la colonne contenant la fonction NB.SI (colonne D dans mon exemple);

Résultat de détection des doublons avec la fonction NB.SI

2.       Ensuite, allez sur l’onglet Données puis dans le groupe Trier et filtrer et cliquez sur le bouton Filtrer pour appliquer le filtre automatique Excel à vos données;

Cliquer sur le bouton Filtrer

3.       Ainsi, en cliquant sur le bouton Filtrer une flèche apparaît dans l’entête de la colonne D. Cliquez dessus et ensuite, dans la liste des valeurs, décochez la valeur 1. Cela permet de garder seulement les doublons.

Filtrer les doublons

4.       Maintenant vous pouvez supprimer ces doublons en les sélectionnant puis en faisant un clic droit dessus et en sélectionnant l’option Supprimer la ligne.

Supprimer les doublons filtrés

5.       Finalement, supprimez le filtre en répétant la procédure de l’étape 3 mais en cochant la case correspondante à « 1 ». Et voilà votre ensemble de données sans doublons:

Enfin, supprimez la colonne contenant la fonction NB.SI.

Résultat de la suppession des doublons avec NB.SI

Cet article a 2 commentaires

  1. Very nice post. I just stumbled upon your blog and wished to say
    that I have really enjoyed surfing around your blog posts.
    After all I’ll be subscribing to your feed and I hope you write again very soon!

  2. I know this if off topic but I’m looking into starting my
    own weblog and was curious what all is required to get setup?
    I’m assuming having a blog like yours would
    cost a pretty penny? I’m not very internet savvy so I’m not 100% positive.
    Any tips or advice would be greatly appreciated. Kudos

Laisser un commentaire

Fermer le menu